Blog tvlooy

Building an OpenBSD kiosk

| October 05, 2019

Install OpenBSD the usual way. Add an extra user named "kiosk" during install.

Configure doas:

echo 'permit nopass kiosk' > /etc/doas.conf

Install Chromium:

pkg_add -i chromium

Log in as user kiosk and add the script /home/kiosk/chrome.sh. Make this script executable. See below for the content of the script, replace "<your_homepage>" with the homepage you want to show"

while [ true ]; do /usr/local/bin/chrome --kiosk --no-default-browser-check --disable-session-crashed-bubble https://<your_homepage> done

Add this line to your /home/kiosk/.xinitrc:

/home/kiosk/chrome.sh & exec cwm

Add this line to your /home/kiosk/.profile:

if [ -z "`pgrep xinit`" ]; then xinit -- -nocursor -nolisten tcp fi

Add this line to your /etc/rc.local:

su - kiosk

Next, reboot and your kiosk is ready!